Onder eigen verantwoordelijkheid

An article, posted about 7 years ago filed in , , , , , , , , & .

Het einde van het jaar nadert. Op zich zit het met het aantal opdrachtgevers voor mij dit jaar na 1 jaar zelfstandigheid wel goed. Maar m'n inkomsten leunden dit jaar wel sterk op één opdrachtgever. Hoewel ook in het contract duidelijk wordt gemaakt dat het geen werkgever-werknemer relatie is is er één argument die het onomstotelijk bewijst dat ik de opdracht onder eigen verantwoordelijkheid en zonder gezagsverhouding uitoefen. Eventuele vragen van de belastinginspecteur zou ik dan ook als volgt beantwoorden:

> “Kunt u het zich voorstellen dat iemand bij een grote financiële instelling, een project automatiseert met een relatief onbekende scriptingtaal genaamd ‘ruby’ [1]? Nee toch? Dat moeten toch minimaal Enterprise oplossingen zijn binnen toch minimaal een Microsoft SitePoint of iets dergelijks, niet? Toch doe ik het, en heb ik ze weten te overtuigen van de kracht: simpelweg omdat de meest efficiënte oplossing bleek te zijn voor hun probleem. Geen gedoe over licentie aanvragen …

Continue reading...

[Project] Introducing PortableRails3

An article, posted almost 8 years ago filed in , , , , , , , & .

The InstantRails project is outdated and contains just too much IMHO ( Apache, PHP, who needs that when searching for Rails?). Other options to get Rails running require an installer (RailsInstaller or RubyInstaller )… and in some environments ( limited access accounts ) installing is not an option. And in yet other environments, you'd, well I'd, rather have a command line option, instead of an in-your-face installer that requires end-users to press 'next', 'next', 'next'…So that's why I created Portable Rails 3. It's name was 'inspired' (it's a boring name, I know) by the thoughtfully named Portable Git which makes an excelent companion.Installing is as simple as extracting (or cloning) and running start-cmd.batCreditsI didn't do much besides just throwing the binary stuff together. Stuff that went into the mix (I'll update when I feel its necessary):Ruby 1.9.2PDCurses [1]GDBM  [1]OpenSSL [1]readline [1]Zlib  [1]IconV [1]RubyGems 1.7.2 (updated with update –system )R…

Continue reading...

murb blog